WordPress klaar voor implementeren voorstel voor auto-updates oude WP versies

auto-updates

WordPress contributors van over de hele wereld namen afgelopen week deel aan een levendige discussie, wederom over het voorstel voor automatische updates voor oude WordPress versies naar 4.7. Het idee is dat websites geleidelijk auto-updates zouden krijgen van de ene grote versie naar de volgende (niet allemaal tegelijk). De discussie werd begeleid door Andrew Nacin, die hulp kreeg van Ian Dunn en Jake Spurlock.

Expliciete toestemming

Afgaande op de reacties van de deelnemers was er slechts een handvol dissidenten die het geen goed idee vinden om oude sites te updaten zonder de expliciete toestemming van de site eigenaar. Toestemming die lastig te krijgen is, omdat e-mails en dashboard meldingen niet altijd bij de juiste personen aankomen.

Hosting en Webhosting bij Combell

Volgens Dunn was het doel van de discussies om te “luisteren naar ideeën en hopelijk dichterbij te komen bij een soort beslissing.” De meeting ging van start met een focus op details betreffende marketing en implementatie, in plaats van de vraag of WordPress wel of niet sites automatisch moet updaten naar grote versies.

“Het is het vermelden waard dat deze site eigenaren al tot zes jaar admin meldingen hebben gehad,” zei Nacon. “De oudste sites hebben waarschijnlijk meer dan 30 emails ontvangen. De manier waarop we een nieuwe feature zouden communiceren (in zeg 5.3 of 5.4) om ondersteuning voor grote auto updates toe te voegen zou heel anders zijn dan bij een oude site op 3.7 die we graag naar 3.8 en hoger zouden verhuizen.”

Auto-updates oude WP versies

Zoals hij in de vorige discussies over het onderwerp ook al aangaf, benadrukte Nacin dat het altijd al het plan was om automatische updates voor grote versies te implementeren:

“Ik wil graag een beetje geschiedenis en context delen: Alleen de laatste versie van WordPress is, natuurlijk, officieel ondersteund. Automatische achtergrond updates in 3.7 (oktober 2013) veranderden de calculus volledig – voor het eerst waren we in staat om beveiligingsupdates naar oudere versies uit te brengen. Maar deze oudere versies werden niet aangekondigd of gedocumenteerd, aangeboden als gewone download, of zichtbaar gemaakt op het Dashboard > Updates venster. Er was geen intentie – en die is er nog steeds niet – om verandering te brengen in ons herhaaldelijk verklaarde beleid dat alleen de meest recente versie van WordPress officieel ondersteund is. Maar wat we wel beseften was dat als we de mogelijkheid bouwen om snel beveiligingsupdates naar oudere niet-ondersteunde sites te pushen, we gek zouden zijn om die feature niet te gebruiken.”

“We hadden verwacht om sneller vooruitgang te boeken met automatische updates voor grote versies, door de veiligheid en veerkracht van die updates te verbeteren. Dat zou ons in staat hebben gesteld om die oudere sites, helemaal tot aan 3.7, te updaten naar meer recente versies van WordPress. Dat was altijd al het plan. We hadden alleen niet verwacht dat het ons zes jaar zou kosten om er te komen.”

Ethische vragen

Op een gegeven moment veranderde de discussie omtrent de ethiek van het automatisch updaten van oude sites naar versie 4.7 in analogieën over auto onderhoud, vaccinaties en rottende lijken. Eigenlijk alles dat de deelnemers uit de echte wereld konden trekken waarmee anderen zich konden herkennen in hun meningen over het onderwerp van de discussie.

“Het is moeilijk om over ‘autonomie’ voor sites te praten die in feite verwaarloosd zijn,” zei Mark Jaquith. “Stel dat je dood neervalt op straat, dan laat de maatschappij je daar ook niet wegrotten omdat je geen toestemming hebt gegeven voor een begrafenis.”

Core contributor John James Jacoby zei dat hij het niet helemaal eens is met de geïmpliceerde toestemming van opt-out versus opt-in, maar was het er uiteindelijk mee eens dat het “iets is dat moet gebeuren.”

Maar hij heeft wel het gevoel dat “WordPress niet zijn eigen karkassen van het web moet halen tenzij dit gepaard gaat met een big’ol meta-box in het Dashboard die zegt ‘Hey we moesten dit voor je doen en dit is waarom.’”

Er is nog geen officiële beslissing aangekondigd over auto-updates voor oude WP versies. Maar degenen die de macht hebben om het plan te implementeren zijn vastberaden en lijken in deze laatste discussie een consensus te hebben bereikt.

 

 

Korting op WordPress handleiding

Geef een reactie