SyntaxHighlighter Evolved plugin voegt Gutenberg support toe

syntaxhighlighter evolved plugin

WordPress 5.0 zal een Code block bevatten voor de nieuwe editor, maar daar zit geen syntax highlighter bij. Momenteel wordt de code nog in pre tags verpakt. In het begin van de ontwikkelingsfase van Gutenberg was het HTML block wel voorzien van syntax highlighting. Het team was echter niet tevreden met de implementatie en besloten het voorlopig te schrappen tot het moment dat de blocks zich consistenter gedroegen. Voorlopig zullen gebruikers dus gebruik moeten maken van een plugin als ze Gutenberg willen gebruiken met syntax highlighting. De SyntaxHighlighter Evolved plugin is een van de eerste plugins van zijn soort die Gutenberg support toevoegt via zijn eigen block.

Verder lezen