Minimaal vereiste PHP versie opgeschroefd naar 5.6

minimaal vereiste PHP versie

WordPress heeft de ondersteuning voor PHP 5.2 – 5.5 officieel beëindigd door de minimaal vereiste PHP versie op te schroeven naar 5.6. Websites die draaien op PHP 5.5 zullen nog steeds security updates krijgen, maar zullen niet naar de meest recente WordPress versie kunnen upgraden. Op dit moment draait slechts 2% van alle WordPress websites nog op PHP 5.2. Grofweg 20% zit op versie 5.5 of ouder. Bijna de helft van alle WordPress installaties zit op PHP 7.0+.

Waarom niet meteen naar PHP 7?

Het plan, dat afgelopen december werd aangekondigd, was om de minimaal vereiste versie begin 2019 op te schroeven en vervolgens in december 2019 weer omhoog te gaan naar PHP 7. Je vraagt je nu misschien af waarom WordPress niet gewoon meteen de minimale vereiste opschroeft naar PHP 7. Met hun enorme invloed en dominante marktaandeel, zou een dergelijke vereiste gebruikers dwingen om aan boord te komen. Maar WordPress contributors geloven in het ondersteunen van gebruikers die, om welke reden dan ook, meer tijd of hulp nodig hebben om PHP te upgraden. Het afdwingen van vereisten is nooit de weg geweest die WordPress heeft gekozen, ondanks de jarenlange druk van de ontwikkelaarsgemeenschap.

“Gebruikers achterlaten om technische redenen zou een tweeledig web creëren waarbij slechts enkelen haar ware kracht kunnen benutten,” zei WordPress Core Committer Felix Arntz. “Door met deze gebruikers samen te werken en ze te ondersteunen zorgen we dat die kracht op de lange termijn voor iedereen mogelijk is.”

Minimaal vereiste PHP versie

Gary Pendergast deelde een aantal statistieken met betrekking tot de effectiviteit van de PHP update waarschuwing in WordPress 5.1.

“Voor WordPress 5.0 updateten sites hun PHP versie van PHP <= 5.6 naar PHP 7+ op een snelheid van 1 basispunt per dag. Met andere woorden, het percentage WordPress 5.0 sites dat PHP <= 5.6 gebruikte daalde met 0.01 per dag, voorafgaand aan de release van WordPress 5.1.”

“Voor WordPress 5.1 (na het toevoegen van de update waarschuwing) is dat toegenomen met een gestage 5 basispunten per dag. Klinkt niet als veel? Dat zijn dagelijks honderden extra website-eigenaren die ervoor kiezen om het (eerlijk gezegd angstaanjagende) proces van het updaten van hun PHP versie te doorlopen. Het enige dat ze nodig hadden was een extra duwtje in de rug, en een beetje informatie.”

minimaal vereiste PHP versie

“Geduld en empathie”

“Enge EOL meldingen en houdingen van ‘nou, we schroeven onze vereiste PHP versie omhoog, jammer dat je niet weet wat je nu moet doen’ helpen niet. Wat wel werkt is mensen de informatie geven die ze nodig hebben om zichzelf te helpen.”

“WordPress mensen helpen mee om de verouderde PHP-installaties waar een groot deel van het internet op draait op te schonen, en we zijn erachter gekomen dat dit geen onoverkomelijk probleem is. Het vereist slechts een beetje geduld en empathie om op te lossen.”

WordPress ontwikkelaars over het hele Word Wide Web verstuurden felicitatie tweets na de aankondiging. Hoewel PHP 5.6 voorlopig de nieuwe minimaal vereiste versie is om WordPress te kunnen draaien, wordt gebruikers in de technische specificaties van het project aangeraden om hun hosts te vragen om PHP versie 7.3 of hoger. PHP 7+ biedt namelijk enorme performance winsten voor gebruikers, en ontwikkelaars kunnen hun plugins updaten om meer moderne syntax te gebruiken.

WordPress webhosting

Geef een reactie